httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 18334] New: - Server crashes when authenticating users against LDAP server
Date Tue, 25 Mar 2003 19:49:43 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=18334>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=18334

Server crashes when authenticating users against LDAP server

           Summary: Server crashes when authenticating users against LDAP
                    server
           Product: Apache httpd-2.0
           Version: 2.0.44
          Platform: PC
        OS/Version: Windows NT/2K
            Status: NEW
          Severity: Major
          Priority: Other
         Component: mod_auth_ldap
        AssignedTo: bugs@httpd.apache.org
        ReportedBy: phil@flare.demon.co.uk


Downloaded apache 2.0.44 for WinNT.
Installed it and configured it to support webDAV, uncomment the dav and davfs 
loadmodule lines.
Configured Apache to support webDAV on one directory.
Confirmed webDAV was working.
Then configured the same directory to require a valid user, by adding the lines 
to support for the utils_ldap module, and the mod_auth_ldap module. Then 
configured the appropriate LDAP directives as shown:-

LDAPSharedCacheSize 200000
LDAPCacheEntries 1024
LDAPCacheTTL 600
LDAPOpCacheEntries 1024
LDAPOpCacheTTL 600
DavLockDB "C:/temp/DavLock"

<Directory "C:/Program Files/Apache Group/Apache2/htdocs/dav">
	AuthType Basic
	AuthName "WebDAV Auth to LDAP server"
	AuthLDAPEnabled on
	AuthLDAPURL "ldap://169.192.1.31:2890/ou=People,o=jpmchase,o=jpmc?uid?
one"
	AuthLDAPAuthoritative on
	Options -Indexes
	Dav On

	<LimitExcept GET HEAD OPTIONS>
		allow from all
		require valid-user
	</LimitExcept>
</Directory>

Now when ever I access the dav directory Apache prompts for the username and 
password, after inputting them it crashes.

This is repeatable and the application event viewer reports

The application, , generated an application error The error occurred on  
3/25/2003 @ 16:22: 7.108 The exception generated was c0000005 at address 
77957d70 (ldap_result) 

The error log reports

[Tue Mar 25 16:24:14 2003] [notice] Parent: child process exited with status 
3221225477 -- Restarting.
[Tue Mar 25 16:24:14 2003] [notice] Parent: Created child process 644
[Tue Mar 25 16:24:14 2003] [notice] Child 644: Child process is running
[Tue Mar 25 16:24:15 2003] [notice] Child 644: Acquired the start mutex.
[Tue Mar 25 16:24:15 2003] [notice] Child 644: Starting 250 worker threads

I then created another directory called test and didn't configure this for 
webdav support, but did have it protected.  When accessing it with a browser it 
asked for my username and password and then again crashed with the same error.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message