httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 18191] New: - DirectoryIndex generates wrong URL when SSL enabled
Date Thu, 20 Mar 2003 16:38:50 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=18191>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=18191

DirectoryIndex generates wrong URL when SSL enabled

           Summary: DirectoryIndex generates wrong URL when SSL enabled
           Product: Apache httpd-2.0
           Version: 2.0.44
          Platform: Sun
        OS/Version: Solaris
            Status: NEW
          Severity: Blocker
          Priority: Other
         Component: mod_dir
        AssignedTo: bugs@httpd.apache.org
        ReportedBy: jsp@usp.org


On both 2.0.43 and 2.0.44 I have the following problem.  An SSL-only server,
listening on 443, receives a request something like the following:

https://site.usp.org/dir/

The server replies with the following:

HTTP/1.1 302 
Date: Thu, 20 Mar 2003 16:03:32 GMT
Server: Apache/2.0
Location: http://site.usp.org:443/dir/index.html
Content-Type: text/html;charset=ISO-8859-1
Content-Language: en
Transfer-Encoding: chunked

This will fail because the server is a) only listening on 443 and b) is
expecting SSL traffic there, not unencrypted requests.

I'm assuming this is a problem with mod_dir, but that's just a guess.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message