httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 17856] New: - Chinese encode error
Date Tue, 11 Mar 2003 03:57:38 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=17856>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=17856

Chinese encode error

           Summary: Chinese encode error
           Product: Apache httpd-2.0
           Version: 2.0.32
          Platform: PC
        OS/Version: Linux
            Status: NEW
          Severity: Normal
          Priority: Other
         Component: All
        AssignedTo: bugs@httpd.apache.org
        ReportedBy: ken@econ.yorku.ca


After build a Chinese webpage by Dreamwaver( Chinese vision), I can see DOC at 
local,But after send DOC to server, The encode is in (ISO)
I did at a line at header of DOC, set encode to gb2312. and it display at local 
very well. I ftp the file to geocities at yahoo, it display ok too.

but why not working at my REDHAT 8.0 server. I had to reset IE at 
view-code-change to gb2312, then I can see the DOC.

Under Win2K Chinese vision. I used notepad build a html file.
there are 4 option for encode. one is gb2312, UTF-8 , ANSI, only file save as 
UTF-8 give me right result. (<meta http-equiv="Content-Type" 
content="text/html; charset=utf-8"> was added at every file.)
however I check IE, it is using gb2312 to decode!

the file build by CGI works OK too.

sample ( this two page is not cgi files)
 http://199.212.79.128/t/ansi.html error
 http://199.212.79.128/t/utf8.htm   OK

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message