httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 17500] - Memory Leak from use of initgroups()
Date Thu, 27 Feb 2003 17:05:12 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=17500>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=17500

Memory Leak from use of initgroups()





------- Additional Comments From sherod@pillardata.com  2003-02-27 17:05 -------
 I'm not making a lot of hits against httpd with my tests, for example last 
time I saw valgrind report the leak 17 times with basically that number of 
connections.  My httpd.conf file contains: 
 
<IfModule worker.c> 
StartServers         1 
MaxClients         150 
MinSpareThreads     25 
MaxSpareThreads     75 
ThreadsPerChild     25 
MaxRequestsPerChild  0 
</IfModule> 
 
Looks like perchild might also call initgroups, but I'm not using that.  My 
only call is along the path mentioned. 
 
I've not tested anything but with nis/yp on Linux.  I don't have anything like 
valgrind on QNX; there I merely checked initgroups() in a tight loop.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message