httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 17065] New: - apache will not start due to what appears to be a shared library error : mod_vhost_alias.so: symbol ap_os_is_path_absolute: referenced symbol not found
Date Thu, 13 Feb 2003 23:15:27 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=17065>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=17065

apache will not start due to what appears to be a shared library error : mod_vhost_alias.so:
symbol ap_os_is_path_absolute: referenced symbol not found

           Summary: apache will not start due to what appears to be a shared
                    library error : mod_vhost_alias.so: symbol
                    ap_os_is_path_absolute: referenced symbol not found
           Product: Apache httpd-1.3
           Version: 1.3.27
          Platform: Sun
        OS/Version: Solaris
            Status: NEW
          Severity: Major
          Priority: Other
         Component: mod_vhost_alias
        AssignedTo: bugs@httpd.apache.org
        ReportedBy: jerry.bonner@cpinternet.com


This question was asked on the mailing list by someone else, but theres was no 
response :
http://marc.theaimsgroup.com/?l=apache-httpd-users&m=103713827221626&w=2

apache 1.3.27
modssl 2.8.12
openssl 0.9.7
SunOS 5.8 Generic_108528-12 sun4u sparc SUNW,Ultra-80

# /usr/local/apache-1.3.27/bin/apachectl configtest
Syntax error on line 212 of /usr/local/apache-1.3.27/conf/httpd.conf:
Cannot load /usr/local/apache-1.3.27/libexec/mod_vhost_alias.so into server: 
ld.so.1: /usr/local/apache-1.3.27/bin/httpd: fatal: relocation error: 
file /usr/local/apache-1.3.27/libexec/mod_vhost_alias.so: symbol 
ap_os_is_path_absolute: referenced symbol not found
# ldd -r /usr/local/apache-1.3.27/libexec/mod_vhost_alias.so 
        symbol not found: __ctype               (/usr/local/apache-
1.3.27/libexec/mod_vhost_alias.so)
        symbol not found: ap_os_is_path_absolute                
(/usr/local/apache-1.3.27/libexec/mod_vhost_alias.so)
        symbol not found: ap_table_setn         (/usr/local/apache-
1.3.27/libexec/mod_vhost_alias.so)
        symbol not found: tolower               (/usr/local/apache-
1.3.27/libexec/mod_vhost_alias.so)
        symbol not found: ap_pstrcat            (/usr/local/apache-
1.3.27/libexec/mod_vhost_alias.so)
        symbol not found: ap_pcalloc            (/usr/local/apache-
1.3.27/libexec/mod_vhost_alias.so)
        symbol not found: ap_pstrdup            (/usr/local/apache-
1.3.27/libexec/mod_vhost_alias.so)
        symbol not found: ap_get_server_name            (/usr/local/apache-
1.3.27/libexec/mod_vhost_alias.so)
        symbol not found: strstr                (/usr/local/apache-
1.3.27/libexec/mod_vhost_alias.so)
        symbol not found: strcasecmp            (/usr/local/apache-
1.3.27/libexec/mod_vhost_alias.so)
        symbol not found: ap_get_server_port            (/usr/local/apache-
1.3.27/libexec/mod_vhost_alias.so)
        symbol not found: ap_snprintf           (/usr/local/apache-
1.3.27/libexec/mod_vhost_alias.so)
        symbol not found: strspn                (/usr/local/apache-
1.3.27/libexec/mod_vhost_alias.so)
# ldd /usr/local/apache-1.3.27/bin/httpd 
        libsocket.so.1 =>        /usr/lib/libsocket.so.1
        libnsl.so.1 =>   /usr/lib/libnsl.so.1
        libpthread.so.1 =>       /usr/lib/libpthread.so.1
        libc.so.1 =>     /usr/lib/libc.so.1
        libdl.so.1 =>    /usr/lib/libdl.so.1
        libmp.so.2 =>    /usr/lib/libmp.so.2
        libthread.so.1 =>        /usr/lib/libthread.so.1
        /usr/platform/SUNW,Ultra-80/lib/libc_psr.so.1

openssl compiled :

./config shared --openssldir=/usr/local/openssl-0.9.7 no-idea no-threads -fPIC

modssl compiled :

./configure --with-apache=../apache_1.3.27 --enable-shared=ssl --with-
ssl=../openssl-0.9.7 --disable-rule=SSL_COMPAT

apache compiled :

SSL_BASE=/export/install/openssl-0.9.7 ./configure --enable-module=ssl --
prefix=/usr/local/apache-1.3.27 --enable-shared=max --enable-module=most --
disable-rule=SSL_COMPAT

I have 1.3.22 running on this same box with no problems.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message