httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 16573] New: - semaphores aren't cleaned correctly
Date Wed, 29 Jan 2003 23:29:53 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=16573>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=16573

semaphores aren't cleaned correctly

           Summary: semaphores aren't cleaned correctly
           Product: Apache httpd-1.3
           Version: 1.3.27
          Platform: PC
        OS/Version: Linux
            Status: NEW
          Severity: Normal
          Priority: Other
         Component: core
        AssignedTo: bugs@httpd.apache.org
        ReportedBy: lehmann@cnm.de


The used semaphores and shared memories aren't cleaned after a 'apachectl stop'.
So with each restart the old semaphore is remaining in the system. After a
certain amount of restarts apache doesn't start any more but quits with the
message in the error log: semget: No space left on device
All the sem's now have to be remove manually with ipcrm.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message