httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 16521] New: - caches MUST treat invalid Expires values as in the past
Date Wed, 29 Jan 2003 00:15:38 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=16521>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=16521

caches MUST treat invalid Expires values as in the past

           Summary: caches MUST treat invalid Expires values as in the past
           Product: Apache httpd-2.0
           Version: HEAD
          Platform: All
               URL: http://coad.measurement-factory.com/cgi-
                    bin/coad/GraseInfoCgi?session=bug&info_id=test_clause/rf
                    c2616/invalidExpiresMakesStale
        OS/Version: All
            Status: NEW
          Severity: Normal
          Priority: Other
         Component: mod_cache
        AssignedTo: bugs@httpd.apache.org
        ReportedBy: coad@measurement-factory.com


Looks like a possible RFC 2616 MUST violation.
Various malformed Expires header values (including the
"0" value explicitly mentioned by RFC 2616) are not
treated as "in the past".
 
See attached trace(s) for details and ways to reproduce
the violation mentioned above.

Test case IDs in the trace link to human-oriented test case
description and RFC quotes, if available.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message