httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 16451] New: - If header check fails when etag test present
Date Mon, 27 Jan 2003 14:24:19 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=16451>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=16451

If header check fails when etag test present

           Summary: If header check fails when etag test present
           Product: Apache httpd-2.0
           Version: 2.0.44
          Platform: PC
        OS/Version: Windows NT/2K
            Status: NEW
          Severity: Normal
          Priority: Other
         Component: mod_dav
        AssignedTo: bugs@httpd.apache.org
        ReportedBy: julian.reschke@gmx.de


Upon PUT, an "If" header checking both for valid lock token and entity tag
fails, at least when the etag was returned by a previous PUT (which returns a
weak etag in the default case).

Request was:

If: (<opaquelocktoken:35c1f976-24af-964a-88f6-9b26ac86938d> [W/"8823-1c-22d9c11"])

Response was:

412 Precondition failed


Error logs says:

The precondition(s) specified by the "If:" header did not match this resource.
At least one failure is because: an entity-tag was specified, but the resource's
actual ETag does not match.  [412, #0]

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message