httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 16275] New: - Error in logging code in ssl_engine_io.c line 1027
Date Mon, 20 Jan 2003 21:53:57 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=16275>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=16275

Error in logging code in ssl_engine_io.c line 1027

           Summary: Error in logging code in ssl_engine_io.c line 1027
           Product: Apache httpd-2.0
           Version: 2.0.43
          Platform: All
        OS/Version: Other
            Status: NEW
          Severity: Normal
          Priority: Other
         Component: mod_ssl
        AssignedTo: bugs@httpd.apache.org
        ReportedBy: Kenneth.Lerman@se-ltd.com


While trying to track down a problem I'm having using ssl, I enable error 
logging at the debug level.  The log showed:

[Mon Jan 20 16:07:03 2003] [debug] ssl_engine_io.c(1027): OpenSSL: read 132/132 
bytes from BIO#bogus %p[mem: bogus %p
                                      k@Ši@
[Mon Jan 20 16:07:03 2003] [debug] ssl_engine_io.c(974): +----------------------
---------------------------------------------------

The bogus %p messages are caused by the fact that apr_snprintf "enhances" the 
printf standard in that it requires a modifier of 'p', 'A', or 'I' after a %p.

ssl_engine_io.c(1027) should be modified to change '%p' to '%pp' in two places, 
I believe.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message