httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 15957] New: - Cannot compile http-2.0.43 due to incompatible ssl
Date Fri, 10 Jan 2003 14:41:45 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=15957>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=15957

Cannot compile http-2.0.43 due to incompatible ssl

           Summary: Cannot compile http-2.0.43 due to incompatible ssl
           Product: Apache httpd-2.0
           Version: 2.0.43
          Platform: Sun
        OS/Version: Solaris
            Status: NEW
          Severity: Blocker
          Priority: Other
         Component: Build
        AssignedTo: bugs@httpd.apache.org
        ReportedBy: dcarlson@sunlab.unitedspacealliance.com


We are running Sun Solaris 8 MU6 and have OpenSSL-0.9.7 installed. When I
attempt to configure and make http-2.0.43 I get:

bin/bash /local/tools/httpd-2.0.43/srclib/apr/libtool --silent --mode=link gcc -
g -O2 -pthreads    -DSOLARIS2=8 -D_POSIX_PTHREAD_SEMANTICS -D_REENTRANT -DAP_HAVE_
DESIGNATED_INITIALIZER   -I/local/tools/httpd-2.0.43/srclib/apr/include -I/local/t
ools/httpd-2.0.43/srclib/apr-util/include -I/local/tools/httpd-2.0.43/srclib/apr-u
til/xml/expat/lib -I. -I/local/tools/httpd-2.0.43/os/unix -I/local/tools/httpd-2.0
.43/server/mpm/prefork -I/local/tools/httpd-2.0.43/modules/http -I/local/tools/htt
pd-2.0.43/modules/filters -I/local/tools/httpd-2.0.43/modules/proxy -I/local/tools
/httpd-2.0.43/include -I/usr/local/openssl/include/openssl -I/usr/local/openssl/in
clude -I/local/tools/httpd-2.0.43/modules/dav/main -export-dynamic -L/local/tools/
httpd-2.0.43/srclib/apr-util/xml/expat/lib -L/usr/local/openssl/lib -R/usr/local/o
penssl/lib   -o dftables -L/local/tools/httpd-2.0.43/srclib/apr-util/xml/expat/lib
 -L/usr/local/openssl/lib -R/usr/local/openssl/lib dftables.lo -lssl -lcrypto^M
/usr/local/sparc-sun-solaris2.8/bin/ld: skipping incompatible /usr/local/openssl/l
ib/libssl.a when searching for -lssl^M
/usr/local/sparc-sun-solaris2.8/bin/ld: skipping incompatible /usr/local/openssl/l
ib/libssl.a when searching for -lssl^M
/usr/local/sparc-sun-solaris2.8/bin/ld: cannot find -lssl^M
collect2: ld returned 1 exit status^M
*** Error code 1^M
make: Fatal error: Command failed for target `dftables'^M
Current working directory /local/tools/httpd-2.0.43/srclib/pcre^M
*** Error code 1^M

Why is http incompatible with Openssl-0.9.7?
What can we do to resolve this problem?

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message