httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 15889] New: - PHP 4.x and Apache 2.0 compile errors
Date Wed, 08 Jan 2003 15:46:49 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=15889>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=15889

PHP 4.x and Apache 2.0 compile errors

           Summary: PHP 4.x and Apache 2.0 compile errors
           Product: Apache httpd-2.0
           Version: 2.0.40
          Platform: Other
        OS/Version: Linux
            Status: NEW
          Severity: Critical
          Priority: Other
         Component: All
        AssignedTo: bugs@httpd.apache.org
        ReportedBy: luke_jamroz@vfc.com


Can not compile php as a DSO.  Default installation of Apache 2.0.4 included 
with RedHat 8.0 and a basic configuration of PHP 4.1.2 or 4.2.3 or 4.3. (Clean 
install of RedHat 8.0)  I get errors when trying to make install.  After 
reviewing tons of message boards, I was not able to find a single person that 
could compile apache 2.0 with any version of PHP.  Any help would be greatly 
appreciated.  I've opened a bug with PHP people and they closed it out and 
requested that I open a bug with you guys.  Any version above 4.1.2 would work 
for me...

Here is the error message:

[2003-01-07 10:29:15] luke_jamroz@vfc.com

very simple configure:

./configure --with-oci8=/u01/app/oracle/product/oraprod
--with-apxs2=/usr/sbin/apxs
--with-oracle=/u01/app/oracle/product/oraprod



when I run make:



 ext/standard/http_fopen_wrapper.lo ext/standard/php_fopen_wrapper.lo
ext/standard/credits.lo ext/standard/css.lo
ext/standard/var_unserializer.lo ext/standard/ftok.lo
ext/standard/aggregation.lo ext/standard/sha1.lo
ext/tokenizer/tokenizer.lo ext/xml/xml.lo ext/xml/expat/xmlparse.lo
ext/xml/expat/xmlrole.lo ext/xml/expat/xmltok.lo regex/regcomp.lo
regex/regexec.lo regex/regerror.lo regex/regfree.lo TSRM/TSRM.lo
TSRM/tsrm_strtok_r.lo TSRM/tsrm_virtual_cwd.lo main/main.lo
main/snprintf.lo main/spprintf.lo main/php_sprintf.lo main/safe_mode.lo
main/fopen_wrappers.lo main/alloca.lo main/php_ini.lo main/SAPI.lo
main/rfc1867.lo main/php_content_types.lo main/strlcpy.lo
main/strlcat.lo main/mergesort.lo main/reentrancy.lo
main/php_variables.lo main/php_ticks.lo main/streams.lo main/network.lo
main/php_open_temporary_file.lo main/php_logos.lo main/output.lo
main/memory_streams.lo main/user_streams.lo
Zend/zend_language_parser.lo Zend/zend_language_scanner.lo
Zend/zend_ini_parser.lo Zend/zend_ini_scanner.lo Zend/zend_alloc.lo
Zend/zend_compile.lo Zend/zend_constants.lo Zend/zend_dynamic_array.lo
Zend/zend_execute_API.lo Zend/zend_highlight.lo Zend/zend_llist.lo
Zend/zend_opcode.lo Zend/zend_operators.lo Zend/zend_ptr_stack.lo
Zend/zend_stack.lo Zend/zend_variables.lo Zend/zend.lo Zend/zend_API.lo
Zend/zend_extensions.lo Zend/zend_hash.lo Zend/zend_list.lo
Zend/zend_indent.lo Zend/zend_builtin_functions.lo Zend/zend_sprintf.lo
Zend/zend_ini.lo Zend/zend_qsort.lo Zend/zend_multibyte.lo
Zend/zend_execute.lo sapi/cli/php_cli.lo sapi/cli/getopt.lo
main/internal_functions_cli.lo -lcrypt -lresolv -lm -ldl -lnsl -lcrypt
-ldl -lm -lclntsh -locijdbc8 -ldl -lm -lclntsh  -o sapi/cli/php

ext/mysql/libmysql/my_tempnam.lo: In function `my_tempnam':

/usr/src/php-4.3.0/ext/mysql/libmysql/my_tempnam.c:103: the use of
`tempnam' is dangerous, better use `mkstemp'



when I run make install:



Installing PHP CLI binary:        /usr/local/bin/

Installing PHP SAPI module

/usr/lib/httpd/build/instdso.sh
SH_LIBTOOL='/usr/lib/httpd/build/libtool' libphp4.la
/usr/lib/httpd/modules

sh: line 1: /usr/lib/httpd/build/instdso.sh: No such file or directory

apxs:Error: Command failed with rc=8323072

.

make: *** [install-sapi] Error 1

----------------
Server version: Apache/2.0.40
Server built:   Oct  9 2002 08:01:13
Server's Module Magic Number: 20020628:0
Architecture:   32-bit
Server compiled with....
 -D APACHE_MPM_DIR="server/mpm/prefork"
 -D APR_HAS_SENDFILE
 -D APR_HAS_MMAP
 -D APR_HAVE_IPV6
 -D APR_USE_SYSVSEM_SERIALIZE
 -D APR_USE_PTHREAD_SERIALIZE
 -D SINGLE_LISTEN_UNSERIALIZED_ACCEPT
 -D APR_HAS_OTHER_CHILD
 -D AP_HAVE_RELIABLE_PIPED_LOGS
 -D HTTPD_ROOT="/etc/httpd"
 -D SUEXEC_BIN="/usr/sbin/suexec"
 -D DEFAULT_PIDLOG="logs/httpd.pid"
 -D DEFAULT_SCOREBOARD="logs/apache_runtime_status"
 -D DEFAULT_LOCKFILE="logs/accept.lock"
 -D DEFAULT_ERRORLOG="logs/error_log"
 -D AP_TYPES_CONFIG_FILE="conf/mime.types"
 -D SERVER_CONFIG_FILE="conf/httpd.conf"

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message