httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 14335] New: - Problem to apply filters on proxy requests
Date Thu, 07 Nov 2002 10:12:15 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=14335>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=14335

Problem to apply filters on proxy requests

           Summary: Problem to apply filters on proxy requests
           Product: Apache httpd-2.0
           Version: 2.0.43
          Platform: Sun
        OS/Version: Solaris
            Status: NEW
          Severity: Normal
          Priority: Other
         Component: Core
        AssignedTo: bugs@httpd.apache.org
        ReportedBy: tcastelle@generali.fr


We have got a problem applying filters on proxy requests, especially mod_deflate. 

We have an apache 2.0.43 working as a reverse proxy, and we would like him to
compress some files, but not everything (for instance, compress .html but not .gif)

To achieve this, we tried to use AddOutputFilter and AddOutputFilterByType, but
those directives don't work in proxy mode (by the way, can you explain why ? And
is there a futur modification to this restriction ?). However, we tried with
something like that :
<Proxy *.html>
  SetOutputFilter DEFLATE
</Proxy>

It works fine, but we can't add every files we want to compress manually ! 

What we need is something like "Compress all except...". To do this, a directive
like "UnsetOutputFilter" or "SetOutputFilter NONE" should exist (or does it ?).

For the moment, our configuration is like that :

SetOutputFilter DEFLATE
<Proxy *.gif>
  SetOutputFilter NONE
</Proxy>

It works fine, but it's not very "clean" as we now have an error in the
error_log  for each request :
[Thu Nov 07 11:04:35 2002] [error] an unknown filter was not added: NONE

Thanks in advance for any solution you can think of.

Thomas

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message