httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 14328] New: - Apache 2.0.43 fails to compile with Berkeley DB v4.1.24
Date Thu, 07 Nov 2002 06:57:14 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=14328>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=14328

Apache 2.0.43 fails to compile with Berkeley DB v4.1.24

           Summary: Apache 2.0.43 fails to compile with Berkeley DB v4.1.24
           Product: APR
           Version: HEAD
          Platform: PC
        OS/Version: Linux
            Status: NEW
          Severity: Normal
          Priority: Other
         Component: APR-util
        AssignedTo: bugs@httpd.apache.org
        ReportedBy: mark@nolab.conman.org


I was attempting to compile Apache with an already installed Berkeley DB
(v4.1.24, installed for Subversion) and the compile fails. 

Error:

/bin/sh /home/myg/subversion/httpd-2.0.43/srclib/apr/libtool --silent
--mode=compile gcc -g -O2 -pthread   -DHAVE_CONFIG_H -DLINUX=2 -D_REENTRANT
-D_XOPEN_SOURCE=500 -D_BSD_SOURCE -D_SVID_SOURCE -D_GNU_SOURCE  
-I/home/myg/subversion/httpd-2.0.43/srclib/apr-util/include
-I/home/myg/subversion/httpd-2.0.43/srclib/apr-util/include/private 
-I/home/myg/subversion/httpd-2.0.43/srclib/apr/include 
-I/subversion/bdb/include
-I/home/myg/subversion/httpd-2.0.43/srclib/apr-util/xml/expat/lib  -c
apr_dbm_berkeleydb.c && touch apr_dbm_berkeleydb.lo
apr_dbm_berkeleydb.c: In function `vt_db_open':
apr_dbm_berkeleydb.c:200: warning: passing arg 2 from incompatible pointer type
apr_dbm_berkeleydb.c:200: warning: passing arg 4 makes pointer from integer
without a cast
apr_dbm_berkeleydb.c:200: too few arguments to function

Relevant parts of config options:

./configure --enable-so                        \
            --with-dbm=db4                     \
            --with-berkeley-db=/subversion/bdb \
            --with-mpm=prefork

The autoconf scripts should probably check for this.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message