httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 14076] New: - DESTDIR fails for "make install" for xml/expat
Date Wed, 30 Oct 2002 00:30:07 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=14076>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=14076

DESTDIR fails for "make install" for xml/expat

           Summary: DESTDIR fails for "make install" for xml/expat
           Product: Apache httpd-2.0
           Version: 2.0.43
          Platform: All
        OS/Version: All
            Status: NEW
          Severity: Normal
          Priority: Other
         Component: Build
        AssignedTo: bugs@httpd.apache.org
        ReportedBy: james@rcpt.to


"make install DESTDIR=<blah>" currently fails for 2.0.43 in
$SRCBASE/srclib/apr-util/xml/expat. A workaround is to edit
$SRCBASE/srclib/apr-util/xml/expat/Makefile and change line 147 from:
   cd $$dir; $(MAKE) install; cd ..; \

to:
   cd $$dir; $(MAKE) DESTDIR=$(DESTDIR) install; cd ..; \

However I am unsure if this is the proper way to resolve this. Without this, a
"make install DESTDIR=<blah>" tried to mkdirs in the standard $PREFIX
(/usr/local/apache2). Refer bug 9792 "Introduce DESTDIR in Makefiles", and 7803
"make install root= from apache 1.3 doesn't work in 2.0.35".

Thanks ppl. <james@rcpt.to>

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message