httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 14041] New: - httpd.conf errors while reading directives
Date Tue, 29 Oct 2002 09:03:54 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=14041>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=14041

httpd.conf errors while reading directives

           Summary: httpd.conf errors while reading directives
           Product: Apache httpd-2.0
           Version: 2.0.40
          Platform: PC
        OS/Version: Linux
            Status: NEW
          Severity: Normal
          Priority: Other
         Component: mod_vhost_alias
        AssignedTo: bugs@httpd.apache.org
        ReportedBy: tc1024@yahoo.fr


=============== httpd.conf (Apache 2.0.40-8 RedHat 8.0) ============
...

NameVirtualHost *

<VirtualHost a.tck.com *.a.tck.com>
 ...
</VirtualHost>
<VirtualHost b.tck.com *.b.tck.com>
 ...
</VirtualHost>

...
======================== httpd.conf ======================

I've got some errors with this configuration :
1. Like that, only the first VirtualHost works. Then I
   must use my IP as NameVirtualHost.

=> with <NameVirtualHost *> only the first virtualhost works

2. I can't access to hello.b.tck.com for example. If I add
   another VirtualHost (c, after b in httpd.conf), it
   doesn't work too.

=> *.domain can only be used in the first virtualhost.

I don't know if these bugs are fixed in a newer version.
This bug doesn't matter for me but I try to help you to
improve the best webserver of the world. Congratulation.
TCK

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message