httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 13991] New: - Apache hangs abrubtly after 5-6 hours of moderate load
Date Sat, 26 Oct 2002 14:53:23 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=13991>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=13991

Apache hangs abrubtly after 5-6 hours of moderate load

           Summary: Apache hangs abrubtly after 5-6 hours of moderate load
           Product: Apache httpd-2.0
           Version: 2.0.43
          Platform: PC
        OS/Version: Windows NT/2K
            Status: NEW
          Severity: Critical
          Priority: Other
         Component: Platform
        AssignedTo: bugs@httpd.apache.org
        ReportedBy: ivelin@apache.org


We are running Apache 2.0.43 with SSL, mod_proxy and mod_rewrite rules on 
Win2K.
Under moderate load (about 10 requests per second), apache behaves well for 
hours. There are no memory leaks. 
After 5-6 hours ot suddenly pegs the CPU to 100% and stops serving pages.
At the time of the problem, the error log shows that the max threads count has 
been exceeded and apache will restart its child process. 
Apparently the restart doesn't succeed, because the servers stops responding.
It does not crash with an error message. The error log does not suggest 
further problems also.
This scenario is reproducable on 2 independent servers over a period of a week.
There are no signs for external attmept for attack in the log files around the 
time of the hang.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message