httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 11178] - mod_cgi and mod_cgid do not handle buffer flushing well
Date Tue, 08 Oct 2002 15:14:20 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=11178>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=11178

mod_cgi and mod_cgid do not handle buffer flushing well

javier@vrweb.cl changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|RESOLVED                    |REOPENED
         OS/Version|Other                       |Linux
           Priority|Other                       |High
         Resolution|FIXED                       |



------- Additional Comments From javier@vrweb.cl  2002-10-08 15:14 -------
I upgraded my apache to 2.0.43 but the problem still there, i cant get any 
unbuffered perl output with apache (i use it in worker mode). 

$| = 1 just dont work, i have a test in http://desarrollo.vrweb.cl/cgi-
bin/test.pl thats a simple script that set $| = 1 and send 2000 numbers, with a 
line feed and a <br> at the end, with pauses in between. In apache 2.0.39, it 
buffered some numbers and print to screen in parts (big ones) but with this new 
release of apache it just buffer everything and prints only at the end... 

Please check this, print unbuffered perl output is very useful for a lot of 
aplications and i need it a lot :)

Javier Vargas
Santiago, Chile

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message