httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 13277] New: - apache 1.3.27 can not compile in solaris2.8 with gcc
Date Fri, 04 Oct 2002 08:26:44 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=13277>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=13277

apache 1.3.27 can not compile in solaris2.8 with gcc

           Summary: apache 1.3.27 can not compile in solaris2.8 with gcc
           Product: Apache httpd-1.3
           Version: HEAD
          Platform: Sun
        OS/Version: Solaris
            Status: NEW
          Severity: Critical
          Priority: Other
         Component: Build
        AssignedTo: bugs@httpd.apache.org
        ReportedBy: lazykang@hotmail.com


I use the default settings configure Apache 1.3.27
when I build it, it says:

===> src/main
gcc -c  -I../os/unix -I../include   -DSOLARIS2=280 -DNO_DL_NEEDED `../apaci` 
gen_test_char.c
gcc  -DSOLARIS2=280 -DNO_DL_NEEDED `../apaci`   -o gen_test_char 
gen_test_char.o  -lsocket -lnsl -lpthread -lexpat
./gen_test_char >test_char.h
ld.so.1: ./gen_test_char: fatal: libexpat.so.0: open failed: No such file or 
directory

I installed the libexpat manualy,  changed the src/Makefile 
(EXPATLIB=/usr/local/lib),and ran "make" again, it said:
 
util.c: In function `ap_find_token':
util.c:1410: `test_char_table' undeclared (first use in this function)
util.c:1410: (Each undeclared identifier is reported only once
util.c:1410: for each function it appears in.)
util.c:1410: `T_HTTP_TOKEN_STOP' undeclared (first use in this function)
util.c: In function `ap_escape_logitem':
util.c:1487: `test_char_table' undeclared (first use in this function)
util.c:1487: `T_ESCAPE_LOGITEM' undeclared (first use in this function)
util.c: In function `ap_escape_shell_cmd':
util.c:1547: `test_char_table' undeclared (first use in this function)
util.c:1547: `T_ESCAPE_SHELL_CMD' undeclared (first use in this function)
util.c: In function `ap_escape_path_segment':
util.c:1651: `test_char_table' undeclared (first use in this function)
util.c:1651: `T_ESCAPE_PATH_SEGMENT' undeclared (first use in this function)
util.c: In function `ap_os_escape_path':
util.c:1680: `test_char_table' undeclared (first use in this function)
util.c:1680: `T_OS_ESCAPE_PATH' undeclared (first use in this function)

I'm not sure if there is any mistake in apache's sourcecode, but I'm quite sure 
I can install apache1.3.26 with no trouble.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message