httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 13051] - WebApp fails to make due to apr.h on Solaris 2.8
Date Fri, 27 Sep 2002 16:22:01 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=13051>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=13051

WebApp fails to make due to apr.h on Solaris 2.8





------- Additional Comments From jay.ebert@wirelesscar.com  2002-09-27 16:22 -------
Here are the versions:

webapp-module-1.0-tc40
gcc 1.3.4
Solaris 2.8
libtool 1.3.4


Here is the error from make:

wcarweb1:/export/spare/home/web/apache_1.3.26/webapp-module-1.0-tc40 # make

make[1]: Entering directory "lib"
make[1]: Invoking "make  build"
/opt/sfw/bin//gcc -g -O2    -DSOLARIS2=8 -D_POSIX_PTHREAD_SEMANTICS -
D_REENTRANT   -I/export/spare/home/web/apache_1.3.26/webapp-module-1.0-
tc40/apr/include -I/export/spare/home/web/apache_1.3.26/webapp-module-1.0-
tc40/include -c "wa_main.c" -o "wa_main.o"
In file included from /export/spare/home/web/apache_1.3.26/webapp-module-1.0-
tc40/apr/include/apr_general.h:61,
                 from /export/spare/home/web/apache_1.3.26/webapp-module-1.0-
tc40/include/wa.h:77,
                 from wa_main.c:59:
/export/spare/home/web/apache_1.3.26/webapp-module-1.0-
tc40/apr/include/apr.h:198: #error Can not determine the proper size for 
apr_int64_t
/export/spare/home/web/apache_1.3.26/webapp-module-1.0-
tc40/apr/include/apr.h:253: #error Can not determine the proper size for 
ssize_t
/export/spare/home/web/apache_1.3.26/webapp-module-1.0-
tc40/apr/include/apr.h:256: #error Can not determine the proper size for size_t
/export/spare/home/web/apache_1.3.26/webapp-module-1.0-
tc40/apr/include/apr.h:265: #error Can not determine the proper size for 
apr_int64_t
*** Error code 1
make: Fatal error: Command failed for target `wa_main.o'
Current working directory /export/spare/home/web/apache_1.3.26/webapp-module-
1.0-tc40/lib
*** Error code 1
make: Fatal error: Command failed for target `template'
Current working directory /export/spare/home/web/apache_1.3.26/webapp-module-
1.0-tc40
*** Error code 1
make: Fatal error: Command failed for target `lib-build'

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message