httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 12779] New: - Link error for _ap_load_dll_func
Date Wed, 18 Sep 2002 15:33:28 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=12779>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=12779

Link error for _ap_load_dll_func

           Summary: Link error for _ap_load_dll_func
           Product: Apache httpd-2.0
           Version: 2.0.40
          Platform: PC
        OS/Version: Windows XP
            Status: NEW
          Severity: Normal
          Priority: Other
         Component: Core
        AssignedTo: bugs@httpd.apache.org
        ReportedBy: erich.prchal@siemens.at


When I tried to build mod_fastcgi for Apache 2 I got a Link error
could not find symbol _ap_load_dll_func.

I could solve this problem by changing the declaration
  FARPROC ap_load_dll_func(...) 
to:
  AP_DECLARE(FARPROC) ap_load_dll_func(...)
in util_win32.c and os.h

As far as I could see this did not hurt the rest of Apache,
so could you please make this change in the next release.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message