httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 12229] New: - Apache 2 unable to start with php-4.2.2 as module
Date Mon, 02 Sep 2002 14:03:16 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=12229>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=12229

Apache 2 unable to start with php-4.2.2 as module

           Summary: Apache 2 unable to start with php-4.2.2 as module
           Product: Apache httpd-2.0
           Version: 2.0.40
          Platform: PC
        OS/Version: Windows XP
            Status: NEW
          Severity: Major
          Priority: Other
         Component: Other Modules
        AssignedTo: bugs@httpd.apache.org
        ReportedBy: cbaelum@web.de


Installing php-4.2.2 as a module runnig Apache 2.0.39 is working just fine.
I copy the php4ts.dll to my windows/system32. I put these 2 lines into 
httpd.conf:
LoadModule php4_module c:/php-4.2.2-win32/sapi/php4apache2.dll
AddType application/x-httpd-php .php
Restart apache 2.0.39, and a test.php page is showing just fine.

I installed the new Apache 2.0.40, and when I try to restart the service I get 
an error saying:
Cannot load C:/php-4.2.2-Win32/sapi/php4apache2.dll into server: The specified 
procedure could not be found.

One of my coworkers has tried the same on an Windows 2000 platform, and the 
result is the same. Apache 2.0.40 will not start if php is to be loaded as a 
module.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message