httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 11408] New: - send_file function does not work correctly on AIX 4.3.3.0 64 bits
Date Fri, 02 Aug 2002 10:54:55 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=11408>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=11408

send_file function does not work correctly on AIX 4.3.3.0 64 bits

           Summary: send_file function does not work correctly on AIX
                    4.3.3.0 64 bits
           Product: APR
           Version: HEAD
          Platform: Other
        OS/Version: AIX
            Status: NEW
          Severity: Normal
          Priority: Other
         Component: APR
        AssignedTo: bugs@httpd.apache.org
        ReportedBy: es@4js.com


Using Apache 2.0.39 on AIX 4.3.3.0 64 bits. The send_file() give the errno '22' 
(invalid parameter) if the file is equal or bigger than 318 KB.
On this system Apache has compiled using gcc 2.95.3 without binutils package. 
Linker, assembler and ar is coming from AIX distribution.
To compile apache flags '-maix64' should be set for the compiler and the linker.
To use ar and nm tools, you should specify '-X64' before other flags.
The workaround is to specify that you don't want to use sendfile api.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message