httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Vijay Avarachen <stali...@avarachen.net>
Subject Apache1.3.26 compile problem with Slack8.1
Date Fri, 12 Jul 2002 08:14:05 GMT
I attempted to compile apache-1.3.26 on a fresh Slackware 8.1 system and 
got the following output (please see ERROR section).  After a little bit 
research, I updated gawk on my Slack box and everything worked.  I 
updated gawk to 3.1.1.   I hope this helps others out there.  I think it 
had to do with awk not understanding the escape character or something.  

Vijay Avarachen
===========================ERROR==================================

> root@ftp1:/data01/build/apache_1.3.26# ls
> ABOUT_APACHE  INSTALL  Makefile.tmpl  README-WIN.TXT   
>  WARNING-WIN.TXT  conf        configure  icons  src
> Announcement  LICENSE  README          README.configure    cgi-bin   
>       config.layout    htdocs       logs
> root@ftp1:/data01/build/apache_1.3.26# ./configure \
> > --prefix=/data01/www \
> > --enable-shared=max \
> > --enable-modules=most \
> src/helpers/GuessOS: awk: command not found
> Configuring for Apache, Version 1.3.26
> ./configure: awk: command not found
> ./configure: awk: command not found
>  + Warning: Your 'echo' command is slightly broken.
>  + It interprets escape sequences per default. We already
>  + tried 'echo -E' but had no real success. If errors occur
>  + please set the SEO variable in 'configure' manually to
>  + the required 'echo' options, i.e. those which force your
>  + 'echo' to not interpret escape sequences per default.
>  + using installation path layout: Apache (config.layout)
> src/helpers/buildinfo.sh: awk: command not found
> src/helpers/buildinfo.sh: awk: command not found
> src/helpers/buildinfo.sh: awk: command not found
> src/helpers/buildinfo.sh: awk: command not found
> src/helpers/buildinfo.sh: awk: command not found
> src/helpers/buildinfo.sh: awk: command not found
> src/helpers/buildinfo.sh: awk: command not found
> src/helpers/buildinfo.sh: awk: command not found
> src/helpers/buildinfo.sh: awk: command not found
> src/helpers/buildinfo.sh: awk: command not found
> src/helpers/buildinfo.sh: awk: command not found
> src/helpers/buildinfo.sh: awk: command not found
> src/helpers/buildinfo.sh: awk: command not found
> src/helpers/buildinfo.sh: awk: command not found
> src/helpers/buildinfo.sh: awk: command not found
> src/helpers/buildinfo.sh: awk: command not found
> src/helpers/buildinfo.sh: awk: command not found
> src/helpers/buildinfo.sh: awk: command not found
> Creating Makefile
> Creating Configuration.apaci in src
>  + enabling mod_so for DSO support
> ./configure: awk: command not found
> ./Configure: awk: command not found
> ./helpers/CutRule: awk: command not found
> ./helpers/CutRule: awk: command not found
> ./helpers/CutRule: awk: command not found
> ./helpers/CutRule: awk: command not found
> ./helpers/CutRule: awk: command not found
> ./helpers/CutRule: awk: command not found
> ./helpers/CutRule: awk: command not found
> ./helpers/CutRule: awk: command not found
> ./helpers/CutRule: awk: command not found
> ./helpers/CutRule: awk: command not found
> ./helpers/CutRule: awk: command not found
> ./helpers/GuessOS: awk: command not found
> ./Configure: awk: command not found
> ./Configure: awk: command not found
> ./Configure: awk: command not found
> ./Configure: awk: command not found
> ./Configure: awk: command not found
> ./Configure: awk: command not found
> ./Configure: awk: command not found
> ./Configure: awk: command not found
> ./Configure: awk: command not found
> ./Configure: awk: command not found
> ./Configure: awk: command not found
> ./Configure: awk: command not found
> ./Configure: awk: command not found
> ./Configure: awk: command not found
> ./Configure: awk: command not found
> ./Configure: awk: command not found
> ./Configure: awk: command not found
> Creating Makefile in src
>  + configured for Linux platform
>  + setting C compiler to gcc
>  + setting C pre-processor to gcc -E
>  + checking for system header files
>  + adding selected modules
>  + checking sizeof various data types
>  + doing sanity check on compiler and options
> Creating Makefile in src/support
> Creating Makefile in src/os/unix
> Creating Makefile in src/ap
> Creating Makefile in src/main
> root@ftp1:/data01/build/apache_1.3.26# make
> ===> src
> make[1]: Entering directory `/data01/build/apache_1.3.26'
> make[2]: Entering directory `/data01/build/apache_1.3.26/src'
> ===> src/os/unix
> make[3]: *** No rule to make target `/include/ap_config.h', needed by 
> `os.o'.  Stop.
> make[2]: *** [subdirs] Error 1
> make[2]: Leaving directory `/data01/build/apache_1.3.26/src'
> make[1]: *** [build-std] Error 2
> make[1]: Leaving directory `/data01/build/apache_1.3.26'
> make: *** [build] Error 2
> root@ftp1:/data01/build/apache_1.3.26#
> Script done on Fri Jul 12 02:32:34 2002

=============================END ERROR============================



---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message