httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 10678] - REMOTE_USER variable gets dropped when using .htaccess
Date Sun, 14 Jul 2002 06:20:06 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=10678>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=10678

REMOTE_USER variable gets dropped when using .htaccess





------- Additional Comments From josmhinkle@netscape.net  2002-07-14 06:20 -------
.htaccess isn't the problem.  It seems more to be in the use of AddHandler and 
Action.

If a similar simple script exists in the directory and is executable under the 
ExecCGI rules, then REMOTE_USER is passed:
.htaccess:
    AuthType Basic
    AuthName Test
    AuthUserFile /path/to/password/file

    Require valid user (or Require user name)

Then a script in that directory like this shows the environment variable:

test.cgi:
#!/bin/sh
echo "Content-Type: text/plain"
echo
echo "Remote User: $REMOTE_USER"

However, identifying such a script in an Action or Script directive causes the 
variable to be lost somewhere, as in this as well as the case originally 
outlined:

httpd.conf:
Script PUT /path/to/the/above/script

.htaccess:
   AuthType Basic
   AuthName "no REMOTE_USER"
   AuthUserFile /path/to/password/file

   <Limit PUT>
      Require user name
   </Limit>

and the variable REMOTE_USER does not appear.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message