httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 10775] New: - SCRIPT_NAME wrong value
Date Sat, 13 Jul 2002 18:37:07 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=10775>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=10775

SCRIPT_NAME wrong value

           Summary: SCRIPT_NAME wrong value
           Product: Apache httpd-2.0
           Version: 2.0.39
          Platform: All
        OS/Version: Linux
            Status: NEW
          Severity: Critical
          Priority: Other
         Component: mod_rewrite
        AssignedTo: bugs@httpd.apache.org
        ReportedBy: goldt@solidmedia.de


The value of SCRIPT_NAME is wrong in apache 2.0.x...
To test it use apache-1.3.x with 
http://somewhere/printenv.cgi/http://otherplace
then SCRIPT_NAME will be 
/printenv.cgi but with apache-2.0.39
it will be /printenv.cgi/http:

This will also result 
in wrong values from the CGI module in perl
($Q->url(-absolute=>1);) and maybe in PHP somewhere 
else.

I am also hunting a bug in PHP redirection (header('Location: ...')) but i am not sure 
yet if it's a problem in PHP or apache.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message