httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 10488] New: - server lockup in prefork.c
Date Thu, 04 Jul 2002 20:31:25 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=10488>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=10488

server lockup in prefork.c

           Summary: server lockup in prefork.c
           Product: Apache httpd-2.0
           Version: 2.0.39
          Platform: Alpha
        OS/Version: Other
            Status: NEW
          Severity: Major
          Priority: Other
         Component: prefork
        AssignedTo: bugs@httpd.apache.org
        ReportedBy: kcarmich@ipapp.com


My servers are locking up on a regular basis (daily or more), I have added 
enough debug code to trace the lockup to be happening in prefork.c when the a 
process has the accept_mutex and the loop that actually does the accept never 
finishes, all the child processes are stuck waiting for the mutex and the 
process with the mutex is stuck at an accept call.

I have added more debug code to identify what results if any are being returned 
from the accept call that is not causing that process to bail out of that loop 
and unlock the mutex.

this is on an DEC Alpha system running Tru64

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message