httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 10465] New: - mod_ssl does not compile on Windows
Date Thu, 04 Jul 2002 07:38:34 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=10465>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=10465

mod_ssl does not compile on Windows

           Summary: mod_ssl does not compile on Windows
           Product: Apache httpd-2.0
           Version: 2.0.39
          Platform: All
        OS/Version: Windows NT/2K
            Status: NEW
          Severity: Normal
          Priority: Other
         Component: mod_ssl
        AssignedTo: bugs@httpd.apache.org
        ReportedBy: richter@ecos.de


I have tried to compile mod_ssl, as it comes with 2.0.39 on windows with MSVC 6.

I have found the following problems:
1. Libraries paths are not correctly set in mod_ssl.mak. Solution:

in LINK32_OBJS change lib paths to

        "..\..\srclib\openssl\out32dll\ssleay32.lib" \
        "..\..\srclib\openssl\out32dll\libeay32.lib" \

(This occurs two times in the make file, one for release one for debug)

- Tools like awk and bison are normaly not available on windows and they aren't 
necessary, because the results are already part of distribution. Solution:

Delete all sections that refer to awk or bison from mod_ssl.mak and abs.mak

After this changes mod_ssl build and works on windows.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message