httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 7810] - suexec + userdir non-functional in httpd 2.0.35 (possibly related to bug 7791)
Date Wed, 26 Jun 2002 15:05:56 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=7810>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=7810

suexec + userdir non-functional in httpd 2.0.35 (possibly related to bug 7791)





------- Additional Comments From dpk@egr.msu.edu  2002-06-26 15:05 -------
Without the SuexecUserGroup directive set, suexec is never called... nothing
logged to cgi.log and CGIs (including ~user ones) are executed successfully as
the httpd user. With the directive set, suexec is at least called, but it does
not honor ~user... the target uid/gid are set to that of the httpd user and
script execution fails because it is not in the document root.

I did check Bug 9038 before submitting, which states disabling cgid in the
LoadModule should fix it.  I did this (noted in the modules I am loading)
without success.  As I re-read 9038, Alex had success by disabling cgid at
compile time.  Is that the ultimate fix (vs. at LoadModule time) ?

Thanks,
Dennis

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message