httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 9686] New: - Apache's CGI and special characters like ,,,,,...
Date Fri, 07 Jun 2002 07:57:15 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=9686>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=9686

Apache's CGI and special characters like ,,,,,...

           Summary: Apache's CGI and special characters like ,,,,,...
           Product: Apache httpd-2.0
           Version: 2.0.36
          Platform: PC
        OS/Version: Windows NT/2K
            Status: NEW
          Severity: Critical
          Priority: Other
         Component: mod_cgi
        AssignedTo: bugs@httpd.apache.org
        ReportedBy: norbert.goepel@ec-munich.com
                CC: norbert.goepel@ec-munich.com


If you have a simple cgi script "Hello world" and you wants to start this 
script with parameters (e.g. http://www.domain.com/script.cgi?parameter=), 
Apache generates an :
couldn't create child process: 20508: C:/Programme/Apache/Apache2/cgi-
bin/test.pl 
I tried the same with Apache 1.3.24 and there, this problem does not exist.

The problem only exists if you have parameters like ,,,,,. If you use 
a,o,u,... there is no problem. But for international sites, you need all 
characters!
This problem also does not exist if you have text-fields within a <form> 
because the characters will be converted to "%E4", ...

Here the cgi-script:
#!c:/perl/bin/perl
print "Content-type: text/html; charset=ISO-8859-1\n\n";
print "Hello World!!";

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message