httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 9488] - Simple "GET" requests (http 0.9) Behave incorrectly
Date Mon, 03 Jun 2002 20:27:09 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=9488>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=9488

Simple "GET" requests (http 0.9) Behave incorrectly





------- Additional Comments From jwoolley@apache.org  2002-06-03 20:27 -------
Yep, 0.9 is broken.  Not sure if we ever really supported this or not.  What 
I'm seeing: 
---------------------------------------------------- 
root@deepthought:/root# telnet localhost 8530 
Trying 127.0.0.1... 
Connected to localhost. 
Escape character is '^]'. 
GET / 
 
 
 
 
HTTP/1.1 400 Bad Request 
Date: Mon, 03 Jun 2002 20:22:05 GMT 
Server: Apache/2.0.37-dev (Unix) mod_ssl/2.0.37-dev OpenSSL/0.9.6c DAV/2 
PHP/4.3.0-dev 
Content-Length: 460 
Connection: close 
Content-Type: text/html; charset=iso-8859-1 
 
<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN"> 
<html><head> 
<title>400 Bad Request</title> 
</head><body> 
<h1>Bad Request</h1> 
<p>Your browser sent a request that this server could not understand.<br /> 
Reason: You're speaking plain HTTP to an SSL-enabled server port.<br /> 
Instead use the HTTPS scheme to access this URL, please.<br /> 
<blockquote>Hint: <a 
href="https://localhost:8530/"><b>https://localhost:8530/</b></a></blockquote></p>

</body></html> 
Connection closed by foreign host. 
----------------------------------------------------

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message