httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 9540] New: - httpd on Win XP transmit garbage if size >32K
Date Fri, 31 May 2002 14:29:53 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=9540>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=9540

httpd on Win XP transmit garbage if size >32K

           Summary: httpd on Win XP transmit garbage if size >32K
           Product: Apache httpd-1.3
           Version: 1.3.24
          Platform: PC
               URL: http://pmcferrin.ugate.net:81/photos/Live_Nature/
        OS/Version: Windows XP
            Status: NEW
          Severity: Blocker
          Priority: Other
         Component: Other
        AssignedTo: bugs@httpd.apache.org
        ReportedBy: paulmcferrin@worldnet.att.net


In moving my existing Apache 1.3.22 [bindist] (Cygwin based) to my Windows XP 
platform (Cygwin based), I have encountered two problems.  The first problem 
(can't fork) was due to a cygwin problem that required me to rebase all of the 
DLLs.  After rebasing the DLLs, the httpd now starts.  First problem is solved.

Second problem...

When viewing any page that has elements over approx 32KB in size, all bytes 
beyond the 32KB boundary is garbage.  If you have images on the page, only the 
1st 32KB of the image is intact.  The rest is garbage.  The total downloaded 
image size is correct!  If you download a file (http) and save it, only the 1st 
32KB will be correct, the remainder of correct size will be garbage.

When I compare the download images & files with the source file, the diffeence 
begins at byte offset 32769.  Files & elemments less than 32KB in size are 
loaded correctly.  If the HTML page itself is over 32KB (no graphics), the page 
is corrupted beyond the 32KB boundary.

I then upgraded to the latest httpd release for Cygwin [bindist] (1.3.24) and 
the same problem appears.  When I look at the error_log file, there is nothing 
of consequence being logged.  I'm running Cygwin DLL version 1.3.6.

At least one other user on the Cygwin mailing list is having the same problem 
with data corruption beyond 32K on Win XP.  I have made several posts to the 
cygwin mailing lists but no one has taken the bite as it is not clear it is a 
Cygwin problem.  This problem is present only on the Win XP system.  I'm running 
the Professional version.

You can access my webserver on port 81 to see the problem at:

        http://pmcferrin.Ugate.Net:81/photos/Live_Nature/

These images are loaded correctly when using the httpd server on my Win 98 
system or if I point my browser to the hard disk.

In the first problem, the following rebase command was executed (a requirement):

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message