httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 9108] - -DNO_DETACH doesn't work
Date Wed, 15 May 2002 15:42:50 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=9108>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=9108

-DNO_DETACH doesn't work

aaron@apache.org changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |bugs@httpd.apache.org
           Severity|Major                       |Enhancement
             Status|NEW                         |ASSIGNED



------- Additional Comments From aaron@apache.org  2002-05-15 15:42 -------
The -DNO_DETACH flag requires that the httpd process not be the
leader of a process group. This happens automatically if you start
apache under a process management tool like daemontools. If you
start it from the command line in most shells with job-control,
it will automatically start the process as the leader of a new
process group, therefore causing apr_proc_detach() to fail.

I'm going to change this to an enhancement since the error message
should be made more clear (and I volunteer to fix it).

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message