httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 8930] New: - 5-6 request, then no more responses.
Date Thu, 09 May 2002 04:14:31 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=8930>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=8930

5-6 request, then no more responses.

           Summary: 5-6 request, then no more responses.
           Product: Apache httpd-2.0
           Version: 2.0.36
          Platform: PC
        OS/Version: Linux
            Status: NEW
          Severity: Major
          Priority: Other
         Component: mod_ssl
        AssignedTo: bugs@httpd.apache.org
        ReportedBy: robertoldham@robertoldham.com


Brief Description:  Apache server recieves 5 or 6 requests, then on the 6th or
7th request the server hangs.  There is no entry in the access log or error log
for the request that hangs.

Detailed Description:  Configured Apache with "./configure
--prefix=/usr/local/apache-httpd-2.0.36 --enable-so --enable-cache=shared
--enable-mem-cache=shared --enable-deflate=shared --enable-expires
--enable-headers --enable-unique-id=shared --enable-ssl=shared
--with-ssl=/usr/local/openssl --enable-http --disable-autoindex --disable-status
--enable-vhost-alias=shared --disable-userdir"

Built apache and configured a virtual host similar to the following:

NameVirtualHost 192.168.0.209:443
<VirtualHost 192.168.0.209:443>
	ServerName testsite.mydomain
	ServerAlias www.testsite.mydomain
	ServerPath /testsite.mydomain

	DocumentRoot /usr/local/mysecurewebroot
	AliasMatch "^/main.*" /usr/local/mysecurewebroot/main.php

	ServerAdmin webmaster@testsite.mydomain

	<Directory /usr/local/mysecurewebroot>
		Options SymLinksIfOwnerMatch IncludesNOEXEC
		AllowOverride None
		Order Allow,Deny
		Deny from All

		<Files "main.php">
			Allow from All
		</Files>
	</Directory>

	Options SymLinksIfOwnerMatch IncludesNOEXEC
	ErrorLog /usr/local/mysecurelogs/logs/errors.log
	CustomLog /usr/local/mysecurelogs/logs/accesses.log combined
	CustomLog /usr/local/mysecurelogs/logs/request_log \
          "%t %h %{SSL_PROTOCOL}x %{SSL_CIPHER}x \"%r\" %b"

	SSLEngine on
	SSLCipherSuite ALL:!ADH:!EXPORT56:RC4+RSA:+HIGH:+MEDIUM:+LOW:+SSLv2:+EXP:+eNULL
	SSLCertificateFile conf/ssl.crt/mysecureserver.crt
	SSLCertificateKeyFile conf/ssl.key/mysecureserver.key
	SetEnvIf User-Agent ".*MSIE.*" nokeepalive ssl-unclean-shutdown
</VirtualHost>

Where testsite.mydomain is a real domain name.

Thought the alias above specifies a file ending with the .php extension, no php
module or type commands were included in the httpd.conf file.  (If you need the
conf file, let me know.)

Start the server.  Use wget to download file from root directory.  On 6th or 7th
download the connection hangs.

I can use the same server build without error when the SSL module and options
are turned off in the httpd.conf and VirtualHost.

This issue seems very basic, so I am suspecting that there may be a great deal
more information needed to pinpoint the problem.  Please contact me if you need
more information.

Thanks,
Robert

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message