httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 8812] New: - expat in binary is different
Date Sun, 05 May 2002 04:55:47 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=8812>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=8812

expat in binary is different

           Summary: expat in binary is different
           Product: Apache httpd-2.0
           Version: 2.0.35
          Platform: Macintosh
        OS/Version: MacOS X
            Status: NEW
          Severity: Normal
          Priority: Other
         Component: Build
        AssignedTo: bugs@httpd.apache.org
        ReportedBy: dr_mac@mail.utexas.edu


Downloaded from binary: httpd-apache_2.0.35-powerpc-apple-
darwin5.3.tar.gz

removed prebuilt binary and redid ./configure and make.

Everything worked!! So then I tried the standard httpd-2.0.35.tar.gz
and again, kept getting the same _pthread_sigmask error when trying to 
link htpasswd.

So I removed the entire expat subtree from the standard and copied over 
the expat subtree from the binary source then reconfigured the standard 
source. Amazing. It worked.

My question is, why is the expat source different in the binary tarball? Most 
differences included the addition of Darwin to the configure.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message