httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 8536] - problem building worker MPM on Tru64 5.1A
Date Sun, 28 Apr 2002 08:09:10 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=8536>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=8536

problem building worker MPM on Tru64 5.1A





------- Additional Comments From jerenkrantz@apache.org  2002-04-28 08:09 -------
If -pthread was required for compilation/linking/execution of the POSIX
threading library on your system, it should have been correctly determined by
APR_PTHREADS_CHECK in apr/build/apr_threads.m4 (see around line 119).

It might be possible that APR_PTHREADS_CHECK_COMPILE passes without any
arguments.  Can you add the following around line 96:
echo $pthreads_working

You'll have to re-run buildconf to generate a new configure file.

Based on what you say, the output should be:
no
no
yes

I'm guessing it'll just be:
yes

(i.e. it passes simply with a yes - no arguments are needed for pthreads.)

So, what error do you see when you don't have -pthread?  

Also, can you provide your output of config.guess - if we have to override your
check, I need to know your host-tuple so we can add it to apr_hints.m4.

Note to be pedantic: CPPFLAGS is the incorrect variable, you want CFLAGS. 
CPPFLAGS dictates the options to your preprocessor - this flag should be a
compiler option - hence CFLAGS.

Thanks for using Apache!

Mime
View raw message