httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 7824] New: - No SO support in tarball
Date Mon, 08 Apr 2002 01:40:09 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=7824>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=7824

No SO support in tarball

           Summary: No SO support in tarball
           Product: Apache httpd-2.0
           Version: 2.0.35
          Platform: Macintosh
        OS/Version: MacOS X
            Status: NEW
          Severity: Normal
          Priority: Other
         Component: All
        AssignedTo: bugs@httpd.apache.org
        ReportedBy: sctemme@covalent.net


The libtool in the tarball is 1.3.4 from the FreeBSD ports collection (see 
bug 7823). This libtool is from before Darwin/MacOSX existed and can't 
deal with shared libraries on that platform. Building a statically linked 
httpd works perfectly fine, but no SO's can be built. APXS and libtool do not 
emit any warnings about this: they just silently don't build the SO file. 

CVS is not affected by this, because it sucks in the libtool installed by the 
Apple Developer Tools, which is functional save for a one line patch.

The 2.0.32 beta shipped with libtool 1.4.2, which has a quoting problem 
with zsh which is used as /bin/sh on MacOSX and doesn't function 
optimally. I have seen the best results so far with libtool 1.3.5, tweaked to 
generate flat namespace binaries.

Maybe we need to do a darwin-specific source tarball with the correct 
libtool in it.

Mime
View raw message