httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 8064] - NetBSD 1.5.2 build failure with --enable-ssl
Date Wed, 24 Apr 2002 18:25:10 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=8064>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=8064

NetBSD 1.5.2 build failure with --enable-ssl





------- Additional Comments From jnp@napolinet.dk  2002-04-24 18:25 -------
I have looked into this and can build openssl application (at least one that
calls SSL_library_init() ;-)


The failure seems to be caused by a combination of things.

NetBSD 1.5.2 has a crypto lib installed in /usr/lib/libcrypto.so.0.

But the openssl package, which, aside from the ssl lib, installs in its own
crypto lib in /usr/pkg/lib/libcrypto.so.1.

For some reason libcrypto.so.1 is not in the lib path to the linker and hence is
not found during linkage.

Creating a link in /usr/lib to the required crypto lib allowed me to build apache.

I don't understand the apache build process nor netbsd internals well enough to
suggest how to best resolve this issue.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message