httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 8453] New: - apxs uses wrong path-variable for build-dir
Date Wed, 24 Apr 2002 09:05:46 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=8453>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=8453

apxs uses wrong path-variable for build-dir

           Summary: apxs uses wrong path-variable for build-dir
           Product: Apache httpd-2.0
           Version: 2.0.35
          Platform: PC
        OS/Version: Linux
            Status: NEW
          Severity: Normal
          Priority: Other
         Component: Build
        AssignedTo: bugs@httpd.apache.org
        ReportedBy: stephan.wuelfert@fh-hof.de


I am trying to install php 4.2.0 as a DSO-modul for apache 2.0.35. The 
configure-script of php fails with

cannot open /usr/local/build/config_vars.mk: No such file or directory at 
./apxs line 248.

I tracked the error down to the apxs script. In line 69:

get_config_vars("$prefix/build/config_vars.mk",\%config_vars);

I am using the GNU layout. In this layout the build-directory is under 
"/usr/local/share/apache2/build" and the prefix is "/usr/local/"

If I change that to the right path (/usr/local/share/apache2/build/" it works 
and I can compile php. But when i try to make "make install" I get the 
following:

/usr/local/sbin/apxs -i -a -n php4 libphp4.la
/usr/local/build/instdso.sh SH_LIBTOOL='/usr/local/build/libtool' libphp4.la 
/usr/local/libexec
sh: /usr/local/build/instdso.sh: No such file or directory
apxs:Error: Command failed with rc=8323072

It seems thap apxs uses in the lines 418, 443 and 474 the wrong path-variable. 
I think it should be the variable (or path) "$installbuilddir" from the file 
config.layout  in case of "$prefix/build" ??? I do not know how to access that 
variable or how I should do it right, because I am not so familiar with the 
code-structurof apache.

I configured php with following command:

./configure --with-tsrm-pthreads --with-mysql=/usr/local 
--with-imap-ssl=/usr/local --with-gettext --with-imap=/Source/imap-2001a 
--with-gd --with-openssl=/usr/local --with-apxs2=/usr/local/sbin/apxs

and apache 2.0.35 with the following:

./configure --enable-layout=GNU  --enable-info --with-ssl=/usr/local 
--enable-so

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message