httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 8440] New: - mod_include does not recurse when mod_deflate is also configured
Date Tue, 23 Apr 2002 21:42:26 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=8440>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=8440

mod_include does not recurse when mod_deflate is also configured

           Summary: mod_include does not recurse when mod_deflate is also
                    configured
           Product: Apache httpd-2.0
           Version: 2.0.35
          Platform: PC
        OS/Version: Linux
            Status: NEW
          Severity: Normal
          Priority: Other
         Component: mod_include
        AssignedTo: bugs@httpd.apache.org
        ReportedBy: jay@grue.userfriendly.org


I have a virtualhost on a test server that defines the following filters:

<Directory /foo>
AddOutputFilter INCLUDES html
AddOutputFilter INCLUDES shtml
AddOutputFilter DEFLATE html
AddOutputFilter DEFLATE shtml
</Directory>

When the deflate filter is in place, mod_include only does ONE pass over the 
includes, ie, any <!--#include's in the included files are ignored. 

Without the deflate filter, it acts as 1.3.x did, which is to recurse on all 
includes until no more can be expanded.

my 1.3.x uses mod_gzip, which does not interfere with mod_include

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message