httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 7988] New: - DOCUMENT_URI incorrect in mod_autoindex header
Date Thu, 11 Apr 2002 22:59:24 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=7988>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=7988

DOCUMENT_URI incorrect in mod_autoindex header

           Summary: DOCUMENT_URI incorrect in mod_autoindex header
           Product: Apache httpd-2.0
           Version: 2.0.35
          Platform: All
               URL: http://www.murph.org/photos/
        OS/Version: All
            Status: NEW
          Severity: Normal
          Priority: Other
         Component: Modules
        AssignedTo: bugs@httpd.apache.org
        ReportedBy: paul@murph.org


When using a custom header with mod_autoindex (the HeaderName directive), the 
following SSI in the header file produces the URI of the header file, not the 
URI of the directory, as per Apache 1.3.x:

    <!--#echo var="DOCUMENT_URI" -->

See http://www.murph.org/photos/ for an example of what I'm doing.  Yes, that 
server is still on Apache 1.3.22, as I'm still working on getting 2.0.35 stable 
enough to replace it.

I have produced a patch for 2.0.35 which reverts to the old 1.3.x behaviour, 
and have it on test at http://www.murph.org:81/photos/ (not available 100% of 
the time).  I have tested this patch on Solaris 8/SPARC (with recent Sun 
patches), and it seems to achieve the correct result without introducing any 
additional instability.  The patch will follow shortly.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message