httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 7945] New: - configure doesn't work on HP-UX 11.0
Date Thu, 11 Apr 2002 07:17:26 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=7945>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=7945

configure doesn't work on HP-UX 11.0

           Summary: configure doesn't work on HP-UX 11.0
           Product: Apache httpd-2.0
           Version: 2.0.35
          Platform: HP
        OS/Version: HP-UX
            Status: NEW
          Severity: Blocker
          Priority: Other
         Component: All
        AssignedTo: bugs@httpd.apache.org
        ReportedBy: luca.fasolo@ecommerce.it


My machine is:
# uname -a
HP-UX a500 B.11.00 U 9000/800 1517720548 unlimited-user license

I'm using gcc:
# /usr/sbin/swlist | grep gcc
  gcc64                         3.0.2.2001-11-14 GCC (The Gnu Compiler 
Collection)

I've successfully compiled Apache 1.3.23 (also 1.3.24 but I've had to downgrade
for proxy-related problem)

With httpd-2.0.35, running configure I've:
[...]
Checking for Shared Memory Support...

checking for sys/mman.h... yes
checking for MAP_ANON in sys/mman.h... no
checking for mmap... no
checking for munmap... no
checking for shm_open... no
checking for shm_unlink... no
checking for /dev/zero... no
checking for sys/ipc.h... yes
checking for sys/shm.h... yes
checking for sys/file.h... yes
checking for shmget... no
checking for shmat... no
checking for shmdt... no
checking for shmctl... no
checking for kernel/OS.h... no
checking for create_area... no
checking for os2.h... no
/home/updates/httpd-2.0.35/srclib/apr/configure:Error: decision on anonymous 
shared memory allocation method failed
configure failed for srclib/apr
#

I guess that I'm missing something in the configure options (I've
tried with "./configure" and  "./configure --enable-so": the results are
the same), but it is possible that there is some problems cheching 
for shmget, shmat, and shmctl:
# grep shmget /usr/include/sys/shm.h
     extern int shmget(key_t, int, int);
     extern int shmget(key_t, size_t, int);
     extern int shmget();
# grep shmat /usr/include/sys/shm.h
   /* The return value on failure of the shmat(2) system call */
     typedef unsigned short int shmatt_t;
       shmatt_t         shm_nattch;     /* current # attached (accurate) */
       shmatt_t         shm_cnattch;    /* in memory # attached (inaccurate) */
       time_t           shm_atime;      /* last shmat time */
     extern void *shmat(int, const void *, int);
     extern char *shmat();
     extern void *shmat();
        time_t             shm_atime;   /* last shmat time */
#
# grep shmctl /usr/include/sys/shm.h
     extern int shmctl(int, int, struct shmid_ds *);
     extern int shmctl();
#

AFAIK, shmget, shmctl and shmat should be find by configure.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message