httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 7635] New: - httpd segfaults when restarting after adding a virtual host
Date Sat, 30 Mar 2002 17:34:01 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=7635>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=7635

httpd segfaults when restarting after adding a virtual host

           Summary: httpd segfaults when restarting after adding a virtual
                    host
           Product: Apache httpd-2.0
           Version: 2.0.32
          Platform: Sun
        OS/Version: Solaris
            Status: NEW
          Severity: Major
          Priority: Other
         Component: All
        AssignedTo: bugs@httpd.apache.org
        ReportedBy: dnewman@maraudingpirates.org


If I make no changes to httpd.conf I can restart apache to my hearts' content.  
But if I add a virtual host, then when I issue a restart the process dies and 
this is what is in the error log:

[Sat Mar 30 03:44:41 2002] [notice] SIGHUP received.  Attempting to restart
[Sat Mar 30 03:44:41 2002] [notice] seg fault or similar nasty error detected 
in the parent process

gdb backtrace:
#0  0xfeef1ad0 in memcmp ()
   from /usr/platform/SUNW,Ultra-5_10/lib/libc_psr.so.1
#1  0xff33b7c0 in find_entry (ht=0xb3c00, key=0xfed25370, klen=16, val=0x0)
    at apr_hash.c:279
#2  0xff33b930 in apr_hash_get (ht=0xb3c00, key=0xfed25370, klen=-1)
    at apr_hash.c:338
#3  0xff34ab40 in apr_pool_userdata_get (data=0xffbef934, 
    key=0xfed25370 "auth_digest_init", pool=0xb3948) at apr_pools.c:1568
#4  0xfed21b94 in initialize_module (p=0xfed25370, plog=0xdd9f0, 
    ptemp=0x114730, s=0xb7270) at mod_auth_digest.c:381
#5  0x3208c in ap_run_post_config (pconf=0xb5950, plog=0xdd9f0, 
    ptemp=0x114730, s=0xb7270) at config.c:126
#6  0x36b48 in main (argc=735688, argv=0xb5950) at main.c:492

After the process dies I use apachectl start to get it started and everything 
works as expected.

The instructions I use to build a package of apache is at 
http://www.maraudingpirates.org/~dnewman/apache.txt

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message