httpd-apreq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Issac Goldstand <mar...@beamartyr.net>
Subject Re: request perl5.18 compatible version of libapreq2
Date Thu, 13 Mar 2014 17:07:41 GMT
On 08/03/2014 01:03, Murray Eisenberg wrote:
> Apparently at present, libapreq2 will not work with perl 5.18. Is that correct?
> 
> (I'm using the MacPorts port of perl 5.18 under Mac OS X and install perl modules, including
those for apache2 support, using MacPorts. And I'm told that the libapreq2 port available
there has no perl 5.18-compatible sub-port because libapreq2 itself is not yet compatible
with perl 5.18.)
> 
> If so, this is to request a perl 5.18-compatible version of libapreq2.
> 
> [What's involved in creating that? (I'm not a Perl programmer but just need libapreq2
-- actually, a MacPorts port of it -- for use with an Apache server application.)
> 

I didn't see any problems with perl-5.18 and libapreq2.

However, a trivial attempt to install mod_perl with Perl 5.18
(httpd-2.2.10) crashed.  If you want to use the perl-glue for libapreq2
and mod_perl, that can be a problem.  I have no idea if it's a
compatibility issue, or due to my not having compiled mod_perl in
several years now, and having borked something in my rusty toolchain.

Have you asked about this on the mod_perl users list at all?

  Issac


Mime
View raw message