httpd-apreq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Fred Moyer <f...@redhotpenguin.com>
Subject Re: [RELEASE CANDIDATE] libapreq2 2.13 RC
Date Sun, 28 Nov 2010 16:46:18 GMT
On Sun, Nov 28, 2010 at 8:39 AM, Joe Schaefer <joe_schaefer@yahoo.com> wrote:
> I believe this problem isn't new on OSX.  If you
> look at what it's trying to do, it's trying to
> load the version of libapreq2 that's already installed
> on your computer, instead of the one sitting in
> your build tree.
>
>
> What we've been telling users to do is go ahead and
> install before running the tests.

That did the trick, tests are now running.

All of them pass except for upload.t

t/apreq/upload.t .. request has failed (the response code was: 404)
see t/logs/error_log for more details
t/apreq/upload.t .. Dubious, test returned 255 (wstat 65280, 0xff00)
Failed 80/80 subtests

[Sun Nov 28 08:43:30 2010] [error] [client 127.0.0.1] File does not
exist: /Users/phred/dev/libapreq2-2.13/glue/perl/t/htdocs/getfiles-perl-pod

>
>
> ----- Original Message ----
>> From: Fred Moyer <fred@redhotpenguin.com>
>> To: Issac Goldstand <margol@beamartyr.net>
>> Cc: apreq-dev@httpd.apache.org
>> Sent: Sat, November 27, 2010 10:43:02 PM
>> Subject: Re: [RELEASE CANDIDATE] libapreq2 2.13 RC
>>
>> Tests failed to start with Snow Leopard, perl 5.12.2, httpd  2.2.15,
>> Apache-Test 1.34.
>>
>>  Reason: Incompatible library version: mod_apreq2.so requires  version
>> 12.0.0 or later, but libapreq2.3.dylib provides version  11.0.0
>>
>> Looks relevant - was a prereq version bumped for this  release?  Or is
>> my build environment just odd?
>>
>> saving config data  to apache_test_config.pm
>> /Users/phred/dev/sl/httpd2/bin/httpd   -d
>> /Users/phred/dev/libapreq2-2.13/module/t  -f
>> /Users/phred/dev/libapreq2-2.13/module/t/conf/httpd.conf -D  APACHE2
>> using Apache/2.2.15 (prefork MPM)
>> waiting 60 seconds for server to  start: 00:00httpd: Syntax error on
>> line 13 of  /Users/phred/dev/libapreq2-2.13/module/t/conf/httpd.conf:
>> Cannot load
> /Users/phred/dev/libapreq2-2.13/module/apache2/.libs/mod_apreq2.so
>> into  server:
>>dlopen(/Users/phred/dev/libapreq2-2.13/module/apache2/.libs/mod_apreq2.so,
>> 10):  Library not  loaded:
>> /Users/phred/dev/sl/httpd2/lib/libapreq2.3.dylib
>>   Referenced  from:
>> /Users/phred/dev/libapreq2-2.13/module/apache2/.libs/mod_apreq2.so
>>    Reason: Incompatible library version: mod_apreq2.so requires version
>> 12.0.0  or later, but libapreq2.3.dylib provides version 11.0.0
>> waiting 60 seconds  for server to start: 00:04^Z
>>
>> On Thu, Nov 25, 2010 at 11:34 AM, Issac  Goldstand <margol@beamartyr.net>
>>wrote:
>> >
>> > -----BEGIN PGP SIGNED MESSAGE-----
>> > Hash:  SHA1
>> >
>> > After a year and a half, the apreq team would like to  release version
>> > 2.13 of libapreq.  Please test and vote on the following  tarball:
>> >
>> >  http://people.apache.org/~issac/libapreq2-2.13.tar.gz
>> >  http://people.apache.org/~issac/libapreq2-2.13.tar.gz.asc
>> >  http://people.apache.org/~issac/libapreq2-2.13.tar.gz.md5
>> >
>> >  Thanks, folks!
>> >  Issac
>> > -----BEGIN PGP SIGNATURE-----
>> >  Version: GnuPG v1.4.10 (MingW32)
>> > Comment: Using GnuPG with Mozilla -  http://enigmail.mozdev.org/
>> >
>> >  iEYEARECAAYFAkzuulcACgkQ7bEFiW+VIthPngCeN1V8AzC9lsuCWjJt/EsJnZ0r
>> >  DS0AniVDbyqUi6GO74mefdyTACi2wa+5
>> > =OF6j
>> > -----END PGP  SIGNATURE-----
>> >
>> >
>> >  ---------------------------------------------------------------------
>> > To  unsubscribe, e-mail: dev-unsubscribe@perl.apache.org
>> >  For additional commands, e-mail: dev-help@perl.apache.org
>> >
>> >
>>
>
>
>
>

Mime
View raw message