httpd-apreq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "David E. Wheeler" <da...@kineticode.com>
Subject Re: libapreq 2.12 failing with apache 2.2.14
Date Thu, 25 Feb 2010 22:25:59 GMT
Howdy,

Just built libapreq 2.12 on 64 bit CentOS 5.4 with Perl 5.10.1 and Apache 2.2.14, and found
two things I wanted to follow up on here:

1. The build initially failed with this error:

       /usr/lib/libexpat.so: could not read symbols: File in wrong format

   This appears to be because I have 64 bit Apache and apreq, but that library is 32 bit.
To get apreq to use the 64 bit version, I had to configure like so:

       LDFLAGS=-L/usr/lib64 ./configure --with-apache2-apxs=/path/to/apxs

   So is there some way that apreq2's configure script could be updated to look for /usr/lib64
and perhaps /lib64 and /usr/local/lib64 on 64 bit platforms?

2. I got a bunch of Perl test failures, but it looks like they were known. It doesn't look
like this patch has been applied yet:

   http://marc.info/?l=apreq-dev&m=125501679623914

Should it be?

Thanks,

David
Mime
View raw message