httpd-apreq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From mmm zzz <3mmm...@gmail.com>
Subject Re: libapreq2-2.12 +gmake on HP UX
Date Tue, 09 Jun 2009 09:44:26 GMT
Hi,
Yes I do think also that it an option of the HP UX linker that's why I tried
to change the linker pointed by gcc to GNU ld but that give no better
results I tried also to remove the +b option so the compilation stack on the
same point indecating this erro:

 ld: Mismatched ABI (not an ELF file)

I'm just a newbie in the compilation and don't know a lot in the compilers
options and can't deside what to add or to remove to be able to finish the
compilation in HP with GCC or CC.

I would ask also if you there is another alternative to the use of the
libapreq2 library in apache? in fact I use it along with mod_perl. I'm
using  Apache2::Request, Apache2::RequestRec... and other modules which I
don't know if they can be replaced with somthing other from a library I can
install on an itanium.

PS: I installed the library in a HP prolient and sun without problem but
unfortuntly I didn't do in the PA-RISC and Itanium.

Could you please help me resolving these issues.
Thanks for your help

2009/6/9, Bojan Smojver <bojan@rexursive.com>:
>
> On Tue, 2009-06-09 at 09:19 +0100, mmm zzz wrote:
> > gcc: +b: No such file or directory
>
>
> >From memory, +b may be an option used by HP-UX specific linker, so maybe
> GCC gets confused and sees it as a file. Don't have a box to try any
> more... Maybe you need to give it -Wl,+b instead?
>
> --
>
> Bojan
>
>

Mime
View raw message