httpd-apreq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joe Schaefer <joe_schae...@yahoo.com>
Subject Re: [RELEASE CANDIDATE] libapreq2 2.12 RC1
Date Fri, 06 Mar 2009 17:15:18 GMT





----- Original Message ----
> From: Fred Moyer <fred@silverliningnetworks.com>
> To: Joe Schaefer <joe_schaefer@yahoo.com>
> Cc: apreq-dev@httpd.apache.org
> Sent: Friday, March 6, 2009 12:10:15 PM
> Subject: Re: [RELEASE CANDIDATE] libapreq2 2.12 RC1
> 
> Joe Schaefer wrote:
> > Please test and vote on the following tarball and sigfile:
> > 
> > http://people.apache.org/~joes/libapreq2-2.12-RC1.tar.gz
> > http://people.apache.org/~joes/libapreq2-2.12-RC1.tar.gz.asc
> > 
> > I've seeded the dates to be 1 week from today, so let's
> > not dilly-dally please ;-)
> 
> Getting an odd message on OS X but maybe it is my setup.
> 
> OS X 10.5, mod_perl-svn, perl 5.8.8 unthreaded, httpd 2.2.4
> 
> make test:
> 
> waiting 60 seconds for server to start: 00:00httpd: Syntax error on line 17 of 
> /Users/phred/dev/svn/sl/trunk/SL-App/src/libapreq2-2.12/module/t/conf/httpd.conf: 
> Cannot load 
> /Users/phred/dev/svn/sl/trunk/SL-App/src/libapreq2-2.12/module/apache2/.libs/mod_apreq2.so

> into server: Library not loaded: 
> /Users/phred/dev/sl/httpd2/lib/libapreq2.3.dylib

That's the wrong library (it's an old installed version instead of the one from
libapreq2-2.12/library/.libs). Check ldd (maybe oname IIRC) on mod_apreq2.so to
see what the module is actually linked against.

>   Referenced from: 
> /Users/phred/dev/svn/sl/trunk/SL-App/src/libapreq2-2.12/module/apache2/.libs/mod_apreq2.so
>   Reason: Incompatible library version: mod_apreq2.so requires version 11.0.0 or 
> later, but libapreq2.3.dylib provides version 10.0.0



      

Mime
View raw message