httpd-apreq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Fred Moyer" <f...@redhotpenguin.com>
Subject Re: [RELEASE CANDIDATE] libapreq2 2.10 RC1
Date Thu, 13 Nov 2008 07:18:01 GMT
Failed a few tests here, perl 5.8.8, apache 2.2.10, mod_perl 2.0.4
prefork, linux.

Can look at this more tomorrow.

[phred@aircloud perl]$ ./t/TEST -verbose  t/apreq/upload.t
[warning] setting ulimit to allow core files
ulimit -c unlimited; /usr/bin/perl
/home/phred/sl/SL-CP/src/libapreq2-2.10/glue/perl/t/TEST -verbose
't/apreq/upload.t'
/home/phred/sl/httpd2/bin/httpd  -d
/home/phred/sl/SL-CP/src/libapreq2-2.10/glue/perl/t -f
/home/phred/sl/SL-CP/src/libapreq2-2.10/glue/perl/t/conf/httpd.conf -D
APACHE2 -D PERL_USEITHREADS
using Apache/2.2.10 (prefork MPM)

waiting 60 seconds for server to start: .[Wed Nov 12 16:15:21 2008]
[warn] PassEnv variable PERL5LIB was undefined
.
waiting 60 seconds for server to start: ok (waited 0 secs)
server localhost.localdomain:8529 started
t/apreq/upload....
1..80
# Running under perl version 5.008008 for linux
# Current time local: Wed Nov 12 16:15:22 2008
# Current time GMT:   Thu Nov 13 00:15:22 2008
# Using Test.pm version 1.25
# Using Apache/Test.pm version 1.31
request has failed (the response code was: 404)
see t/logs/error_log for more details
 Dubious, test returned 255 (wstat 65280, 0xff00)
 Failed 80/80 subtests

Test Summary Report
-------------------
t/apreq/upload (Wstat: 65280 Tests: 0 Failed: 0)
  Non-zero exit status: 255
  Parse errors: Bad plan.  You planned 80 tests but ran 0.
Files=1, Tests=0,  1 wallclock secs ( 0.04 usr  0.01 sys +  0.50 cusr
0.04 csys =  0.59 CPU)
Result: FAIL
Failed 1/1 test programs. 0/0 subtests failed.
[warning] server localhost.localdomain:8529 shutdown
[  error] error running tests (please examine t/logs/error_log)
[phred@aircloud perl]$ cat t/logs/error_log
[Wed Nov 12 16:13:29 2008] [notice] Apache/2.2.10 (Unix)
mod_apreq2-20051231/2.6.3 mod_perl/2.0.4 Perl/v5.8.8 configured --
resuming normal operations
[Wed Nov 12 16:13:29 2008] [info] Server built: Oct 30 2008 05:08:37
....

Wed Nov 12 16:13:40 2008] [error] [client 127.0.0.1] File does not
exist: /home/phred/sl/SL-CP/src/libapreq2-2.10/glue/perl/t/htdocs/getfiles-binary-httpd
[Wed Nov 12 16:13:40 2008] [info] removed PID file
/home/phred/sl/SL-CP/src/libapreq2-2.10/glue/perl/t/logs/httpd.pid
(pid=17468)
[Wed Nov 12 16:13:40 2008] [notice] caught SIGTERM, shutting down
[Wed Nov 12 16:15:21 2008] [notice] Apache/2.2.10 (Unix)
mod_apreq2-20051231/2.6.3 mod_perl/2.0.4 Perl/v5.8.8 configured --
resuming normal operations
[Wed Nov 12 16:15:21 2008] [info] Server built: Oct 30 2008 05:08:37
[Wed Nov 12 16:15:21 2008] [debug] prefork.c(1001): AcceptMutex:
sysvsem (default: sysvsem)
[Wed Nov 12 16:15:23 2008] [error] [client 127.0.0.1] File does not
exist: /home/phred/sl/SL-CP/src/libapreq2-2.10/glue/perl/t/htdocs/getfiles-binary-httpd
[Wed Nov 12 16:15:23 2008] [info] removed PID file
/home/phred/sl/SL-CP/src/libapreq2-2.10/glue/perl/t/logs/httpd.pid
(pid=17536)
[Wed Nov 12 16:15:23 2008] [notice] caught SIGTERM, shutting down


-------------------------------------------------------------------

[warning] setting ulimit to allow core files
ulimit -c unlimited; /usr/bin/perl
/home/phred/sl/SL-CP/src/libapreq2-2.10/glue/perl/t/TEST -bugreport
-verbose=0
/home/phred/sl/httpd2/bin/httpd  -d
/home/phred/sl/SL-CP/src/libapreq2-2.10/glue/perl/t -f
/home/phred/sl/SL-CP/src/libapreq2-2.10/glue/perl/t/conf/httpd.conf -D
APACHE2 -D PERL_USEITHREADS
using Apache/2.2.10 (prefork MPM)

waiting 60 seconds for server to start: .[Wed Nov 12 16:13:29 2008]
[warn] PassEnv variable PERL5LIB was undefined
.
waiting 60 seconds for server to start: ok (waited 0 secs)
server localhost.localdomain:8529 started
t/api/cookie.........ok
t/api/error..........ok
t/api/module.........ok
t/api/param..........ok
t/apreq/big_input....ok
t/apreq/cgi..........skipped: (no reason given)
t/apreq/cookie.......ok
t/apreq/cookie2......ok
t/apreq/inherit......ok
t/apreq/request......ok
t/apreq/upload.......request has failed (the response code was: 404)
see t/logs/error_log for more details
t/apreq/upload....... Dubious, test returned 255 (wstat 65280, 0xff00)
 Failed 80/80 subtests

Test Summary Report
-------------------
t/apreq/upload   (Wstat: 65280 Tests: 0 Failed: 0)
  Non-zero exit status: 255
  Parse errors: Bad plan.  You planned 80 tests but ran 0.
Files=11, Tests=135, 10 wallclock secs ( 1.96 usr  0.03 sys +  6.33
cusr  0.52 csys =  8.84 CPU)
Result: FAIL
Failed 1/11 test programs. 0/135 subtests failed.
[warning] server localhost.localdomain:8529 shutdown
[  error] error running tests (please examine t/logs/error_log)
make[1]: *** [run_tests] Error 1
make[1]: Leaving directory `/home/phred/sl/SL-CP/src/libapreq2-2.10/glue/perl'
make: *** [perl_test] Error 2
[phred@aircloud libapreq2-2.10]$ ls t/

On Wed, Nov 12, 2008 at 10:29 PM, Bojan Smojver <bojan@rexursive.com> wrote:
> It has been over two years since the latest apreq2 release, so it is
> time to get some new code out the door. Numerous bugs were fixed (see
> the full list in the CHANGES file) since the last official release
> (2.08), so please give us feedback on this release candidate.
>
> You can get the tarball, its signature and MD5 checksum from here:
>
> http://people.apache.org/~bojan/libapreq2-2.10-RC1.tar.gz
> http://people.apache.org/~bojan/libapreq2-2.10-RC1.tar.gz.asc
> http://people.apache.org/~bojan/libapreq2-2.10-RC1.tar.gz.md5
>
> Please report any problems back to the list:
>
> apreq-dev@httpd.apache.org
>
> --
> Bojan
>
>

Mime
View raw message