httpd-apreq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "P.V.Anthony" <pvant...@singnet.com.sg>
Subject need help with 64bit Apache2::Request
Date Thu, 02 Oct 2008 11:22:32 GMT
Hi,

Currently I am just not able to get Apache2::Request to work on Gentoo
64bit linux.

Did an install libapreq2-2.08 and all compiled fine.

Did the following test using a simple perl script as follows,

perl test.pl

The contents of test.pl is as follows.

----------- start ------------------

use strict;

use Apache2::Request;

------------ end -------------------



Got the following error,

------------ start ----------------------

Can't load
'/usr/lib64/perl5/site_perl/5.8.8/x86_64-linux-thread-multi/auto/APR/
                                           Request/Apache2/Apache2.so'
for module APR::Request::Apache2: /usr/lib64/perl5/s

ite_perl/5.8.8/x86_64-linux-thread-multi/auto/APR/Request/Apache2/Apache2.so:
un                                              defined symbol:
modperl_xs_sv2request_rec at /usr/lib64/perl5/5.8.8/x86_64-linux
                                      -thread-multi/DynaLoader.pm line 230.
 at
/usr/lib64/perl5/site_perl/5.8.8/x86_64-linux-thread-multi/Apache2/Request.p
                                             m line 3
Compilation failed in require at
/usr/lib64/perl5/site_perl/5.8.8/x86_64-linux-t
                     hread-multi/Apache2/Request.pm line 3.
BEGIN failed--compilation aborted at
/usr/lib64/perl5/site_perl/5.8.8/x86_64-lin
                 ux-thread-multi/Apache2/Request.pm line 3.
Compilation failed in require at test.pl line 3.
BEGIN failed--compilation aborted at test.pl line 3.

-------------- end ----------------------

Next tried the same on a 32bit machine, all compiled fine and the
test.pl also worked without any error.

What am I doing wrong?

P.V.Anthony

Mime
View raw message