httpd-apreq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joe Schaefer <joe+apa...@sunstarsys.com>
Subject Re: apreqXXXXXX temp files remain after processing uploads greater than 256kb. Further large upload fails
Date Thu, 19 Apr 2007 05:22:03 GMT
Randy Kobes <randy@theoryx5.uwinnipeg.ca> writes:

> I've tried this just using the sleep() - the printf stuff
> doesn't work on Win32.

Hm. Try adding an \n or 2 to the error message.

> Unfortunately, I still see some apreqXXXXXX left over in the temp
> directory, very occasionally (this is with perl-5.8.8, Apache/2.2.2,
> mp2 2.000003). I tried a sleep(5), but that didn't help either.
>
> Sometimes, although it's not precisely
> correlated, an entry in the error log appears:
>   $param->upload_tempname($req): can't make spool bucket
>    at ...lib/APR/Request/Param.pm
> which comes from upload_tempname() in APR/Request/Param/Param.xs, which
> indicates that
> apreq_brigade_concat() has failed. However, sometimes
> a stray temp file remains without this error, and
> sometimes this error appears without a stray temp
> file remaining, so I'm not sure they're directly related.
>
> It's a frustrating problem - there doesn't seem to be
> much of a pattern; I can run the tests over and over
> again for 15 minutes without seeing any strays, but
> at other times they appear every few minutes. This machine
> isn't overly busy. The only common thing is that all of
> the temp files for me are copies of the perl.exe
> used in the upload test, and they're identical copies
> to the original.

I'd be happy to write this off as an OS bug if you are.
I wonder if it happens on NT?

-- 
Joe Schaefer

Mime
View raw message